libvorbis.spec 2.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394
  1. %define name libvorbis
  2. %define version 1.0rc3
  3. %define release 1
  4. Summary: The Vorbis General Audio Compression Codec
  5. Name: %{name}
  6. Version: %{version}
  7. Release: %{release}
  8. Group: Libraries/Multimedia
  9. Copyright: BSD
  10. URL: http://www.xiph.org/
  11. Vendor: Xiphophorus <team@xiph.org>
  12. Source: ftp://ftp.xiph.org/pub/ogg/vorbis/%{name}-%{version}.tar.gz
  13. BuildRoot: %{_tmppath}/%{name}-root
  14. Requires: libogg >= 1.0rc3
  15. Prefix: %{_prefix}
  16. %description
  17. Ogg Vorbis is a fully open, non-proprietary, patent-and-royalty-free,
  18. general-purpose compressed audio format for audio and music at fixed
  19. and variable bitrates from 16 to 128 kbps/channel.
  20. %package devel
  21. Summary: Vorbis Library Development
  22. Group: Development/Libraries
  23. Requires: libogg-devel >= 1.0rc3
  24. Requires: libvorbis = %{version}
  25. %description devel
  26. The libvorbis-devel package contains the header files and documentation
  27. needed to develop applications with libvorbis.
  28. %prep
  29. %setup -q -n %{name}-%{version}
  30. %build
  31. if [ ! -f configure ]; then
  32. CFLAGS="$RPM_OPT_FLAGS" ./autogen.sh --prefix=%{_prefix}
  33. else
  34. CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix}
  35. fi
  36. make
  37. %install
  38. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  39. make DESTDIR=$RPM_BUILD_ROOT install
  40. %files
  41. %defattr(-,root,root)
  42. %doc COPYING
  43. %doc AUTHORS
  44. %doc README
  45. %{_libdir}/libvorbis.so.*
  46. %{_libdir}/libvorbisfile.so.*
  47. %{_libdir}/libvorbisenc.so.*
  48. %files devel
  49. %doc doc/*.html
  50. %doc doc/*.png
  51. %doc doc/*.txt
  52. %doc doc/vorbisfile
  53. %doc doc/vorbisenc
  54. %{_datadir}/aclocal/vorbis.m4
  55. %{_includedir}/vorbis/codec.h
  56. %{_includedir}/vorbis/vorbisfile.h
  57. %{_includedir}/vorbis/vorbisenc.h
  58. %{_libdir}/libvorbis.a
  59. %{_libdir}/libvorbis.so
  60. %{_libdir}/libvorbisfile.a
  61. %{_libdir}/libvorbisfile.so
  62. %{_libdir}/libvorbisenc.a
  63. %{_libdir}/libvorbisenc.so
  64. %clean
  65. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  66. %post
  67. /sbin/ldconfig
  68. %postun
  69. /sbin/ldconfig
  70. %changelog
  71. * Sat May 25 2002 Michael Smith <msmith@icecast.org>
  72. - Fixed requires, copyright string.
  73. * Sun Dec 31 2001 Jack Moffitt <jack@xiph.org>
  74. - Updated for rc3 release.
  75. * Sun Oct 07 2001 Jack Moffitt <jack@xiph.org>
  76. - Updated for configurable prefixes
  77. * Sat Oct 21 2000 Jack Moffitt <jack@icecast.org>
  78. - initial spec file created