default.nix 676 B

123456789101112131415161718192021222324252627282930313233
  1. { stdenv
  2. , lib
  3. , rustPlatform
  4. , fetchFromGitHub
  5. , pkg-config
  6. , dbus
  7. , openssl
  8. }:
  9. rustPlatform.buildRustPackage rec {
  10. pname = "tiny-git";
  11. version = "0.9.0";
  12. src = fetchFromGitHub {
  13. owner = "osa1";
  14. repo = "tiny";
  15. rev = "b77c2230bc2ed8b9ffd1ca9c622a0cd0d985cb42";
  16. sha256 = "wRlGzXhq7WDsH2M/bSEHFRTRIAgLr/j5xMGSaUTjhi8=";
  17. };
  18. cargoSha256 = "0vcOSHQ67UxsCJtUB6PsnwM072HBxdTGxGwHu6KRokU=";
  19. nativeBuildInputs = [ pkg-config ];
  20. buildInputs = [ dbus openssl ];
  21. meta = with lib; {
  22. description = "A console IRC client";
  23. homepage = "https://github.com/osa1/tiny";
  24. license = licenses.mit;
  25. maintainers = with maintainers; [ vyp ];
  26. };
  27. }