default.nix 819 B

123456789101112131415161718192021222324252627282930313233
  1. with import <nixpkgs> {};
  2. with xorg;
  3. let
  4. enableXinerama = true;
  5. in stdenv.mkDerivation rec {
  6. name = "setroot-${version}";
  7. version = "2.0.1";
  8. src = fetchFromGitHub {
  9. owner = "ttzhou";
  10. repo = "setroot";
  11. rev = "v${version}";
  12. sha256 = "01krjfc3xpp0wbqz9nvf1n34gkpd41gysn289sj1wcjxia4n4gsi";
  13. };
  14. buildInputs = [ libX11 imlib2 ]
  15. ++ stdenv.lib.optional enableXinerama libXinerama;
  16. buildFlags = "CC=cc "
  17. + (if enableXinerama then "xinerama=1" else "xinerama=0");
  18. installFlags = "DESTDIR=$(out) PREFIX=";
  19. meta = with stdenv.lib; {
  20. description = "Simple X background setter inspired by imlibsetroot and feh";
  21. homepage = "https://github.com/ttzhou/setroot";
  22. license = licenses.gpl3Plus;
  23. maintainers = with maintainers; [ vyp ];
  24. platforms = platforms.unix;
  25. };
  26. }