minimal.nix 659 B

12345678910111213141516171819202122232425262728293031323334353637
  1. { config, pkgs, ... }:
  2. {
  3. imports =
  4. [
  5. /mnt/etc/nixos/hardware-configuration.modified.nix
  6. ];
  7. networking.hostName = "nixos";
  8. networking.wireless.enable = true;
  9. i18n = {
  10. consoleFont = "Lat2-Terminus16";
  11. consoleKeyMap = "us";
  12. defaultLocale = "en_US.UTF-8";
  13. };
  14. time.timeZone = "Australia/Sydney";
  15. nix.nixPath = [
  16. "nixos-config=/home/u/dots/nixos/config.nix"
  17. "nixpkgs=/home/u/nixpkgs"
  18. ];
  19. environment.systemPackages = with pkgs; [
  20. # The packages that ../bootstrap script needs.
  21. git
  22. stow
  23. ];
  24. users.extraUsers.u = {
  25. extraGroups = [ "wheel" ];
  26. isNormalUser = true;
  27. uid = 1000;
  28. };
  29. }