PKGBUILD 1.0 KB

12345678910111213141516171819202122232425262728293031323334
  1. # Maintainer: txtsd <aur.archlinux@ihavea.quest>
  2. pkgname=python-syncedlyrics
  3. _pkgname=syncedlyrics
  4. pkgver=0.4.0
  5. pkgrel=2
  6. pkgdesc='Get an LRC format (synchronized) lyrics for your music'
  7. arch=('any')
  8. url='https://github.com/rtcq/syncedlyrics'
  9. license=('MIT')
  10. depends=('python>=3.7' 'python-requests>=2.28.1' 'python-rapidfuzz>=2.13.2'
  11. 'python-beautifulsoup4>=4.11.1')
  12. makedepends=('python-build' 'python-installer' 'python-wheel'
  13. 'python-poetry-core')
  14. conflicts=("${pkgname}-git")
  15. source=("${_pkgname}-${pkgver}".tar.gz::"https://github.com/rtcq/${_pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
  16. sha256sums=('13672adb05ec6f51c3dafe6efb34b7379c3477f47ffaf9d87d9c1dbf70900956')
  17. build() {
  18. cd "${srcdir}/${_pkgname}-${pkgver}"
  19. GIT_DIR=. python -m build --wheel --no-isolation
  20. }
  21. check() {
  22. cd "${srcdir}/${_pkgname}-${pkgver}"
  23. python -m unittest -v
  24. }
  25. package() {
  26. cd "${srcdir}/${_pkgname}-${pkgver}"
  27. python -m installer --destdir="${pkgdir}" dist/*.whl
  28. install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
  29. }