PKGBUILD 810 B

1234567891011121314151617181920212223242526
  1. # Maintainer: greyltc
  2. # Contributor: txtsd <aur.archlinux@ihavea.quest>
  3. pkgname=python-pox
  4. pkgver=0.3.2
  5. pkgrel=1
  6. pkgdesc="utilities for filesystem exploration and automated builds"
  7. url="https://github.com/uqfoundation/pox"
  8. arch=(any)
  9. license=('BSD')
  10. depends=('python>=3.7')
  11. makedepends=('python-setuptools>=42.0' 'python-build' 'python-installer' 'python-wheel')
  12. source=("${pkgname}-${pkgver}.tar.gz::https://github.com/uqfoundation/pox/archive/refs/tags/pox-${pkgver}.tar.gz")
  13. sha256sums=('4a2573d7b64a4fe3c337b9d996d80089d0920c60d7920f94a4a2d14a8da8b202')
  14. build() {
  15. cd "pox-pox-${pkgver}"
  16. python -m build --wheel --no-isolation
  17. }
  18. package() {
  19. cd "pox-pox-${pkgver}"
  20. python -m installer --destdir="${pkgdir}" dist/*.whl
  21. install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
  22. }