control 8.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219
  1. Source: libjson-rpc-cpp
  2. Priority: extra
  3. Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
  4. XSBC-Original-Maintainer: Peter Spiess-Knafl <dev@spiessknafl.at>
  5. Build-Depends: catch,
  6. cmake,
  7. debhelper (>= 9),
  8. libargtable2-dev,
  9. libcurl4-openssl-dev | libcurl4-nss-dev,
  10. libjsoncpp-dev,
  11. libmicrohttpd-dev
  12. Standards-Version: 3.9.8.0
  13. Section: libs
  14. Homepage: https://github.com/cinemast/libjson-rpc-cpp
  15. Vcs-Git: https://anonscm.debian.org/git/collab-maint/libjson-rpc-cpp.git
  16. Vcs-Browser: https://anonscm.debian.org/cgit/collab-maint/libjson-rpc-cpp.git
  17. Package: libjsonrpccpp-common0
  18. Architecture: any
  19. Pre-Depends: ${misc:Pre-Depends}
  20. Depends: ${misc:Depends}, ${shlibs:Depends}
  21. Suggests: libjsonrpccpp-client0 (= ${binary:Version}),
  22. libjsonrpccpp-server0 (= ${binary:Version}),
  23. libjsonrpccpp-tools (= ${binary:Version})
  24. Description: common functionality for server and client library
  25. This library provides common classes for the libjson-rpc-cpp framework like
  26. .
  27. * Exceptions
  28. * Error-Codes
  29. * Specification Parsers and Writers
  30. * Procedure parameter validation
  31. .
  32. This package usually only makes sense with libjsonrpccpp-client0 and/or
  33. libjsonrpccpp-server0.
  34. Package: libjsonrpccpp-common0-dbg
  35. Architecture: any
  36. Depends: libjsonrpccpp-common0 (= ${binary:Version}),
  37. ${misc:Depends},
  38. ${shlibs:Depends}
  39. Section: debug
  40. Description: debugging symbols for libjsonrpccpp-common0
  41. This library provides common classes for the libjson-rpc-cpp framework like
  42. .
  43. * Exceptions
  44. * Error-Codes
  45. * Specification Parsers and Writers
  46. * Procedure parameter validation
  47. .
  48. This package usually only makes sense with libjsonrpccpp-client0 and/or
  49. libjsonrpccpp-server0.
  50. .
  51. This package contains the debugging symbols for libjsonrpccpp-common0.
  52. Package: libjsonrpccpp-client0
  53. Architecture: any
  54. Pre-Depends: ${misc:Pre-Depends}
  55. Depends: ${misc:Depends}, ${shlibs:Depends}
  56. Suggests: libjsonrpccpp-tools
  57. Description: library implementing json-rpc C++ clients
  58. This library provides classes to easily implement JSON-RPC C++ clients.
  59. It comes with a built in HTTP-Client connector (based on libcurl)
  60. for easy data exchange. It is fully JSON-RPC 2.0 and JSON-RPC
  61. 1.0 compatible, including:
  62. .
  63. * Type checking
  64. * Error response handling
  65. * Batch procedure calls
  66. * JSON-RPC Method invocation
  67. * JSON-RPC Notification invocation
  68. * Interface for additional Client-Connectors beside HTTP
  69. * Positional and named parameters
  70. Package: libjsonrpccpp-client0-dbg
  71. Architecture: any
  72. Depends: libjsonrpccpp-client0 (= ${binary:Version}),
  73. libjsonrpccpp-common0-dbg (= ${binary:Version}),
  74. ${misc:Depends},
  75. ${shlibs:Depends}
  76. Section: debug
  77. Description: debugging symbols for libjsonrpccpp-client0
  78. This library provides classes to easily implement JSON-RPC C++ clients.
  79. It comes with a built in HTTP-Client connector (based on libcurl)
  80. for easy data exchange. It is fully JSON-RPC 2.0 and JSON-RPC 1.0 compatible,
  81. including:
  82. .
  83. * Type checking
  84. * Error response handling
  85. * Batch procedure calls
  86. * JSON-RPC Method invocation
  87. * JSON-RPC Notification invocation
  88. * Simple Interface for implementing additional Client-Connectors beside HTTP
  89. * Positional and named parameters
  90. .
  91. This package contains the debugging symbols for libjsonrpccpp-client0.
  92. Package: libjsonrpccpp-server0
  93. Architecture: any
  94. Pre-Depends: ${misc:Pre-Depends}
  95. Depends: ${misc:Depends}, ${shlibs:Depends}
  96. Suggests: libjsonrpccpp-tools
  97. Description: library implementing json-rpc C++ servers
  98. This library provides classes to easily implement JSON-RPC C++ Server
  99. applications. It comes with a built in HTTP-Server connector
  100. (based on libmicrohttpd) for easy data exchange. It is fully JSON-RPC 2.0 and
  101. JSON-RPC 1.0 compatible, including:
  102. .
  103. * Type checking
  104. * Malformed request handling
  105. * Handling batch procedure calls
  106. * JSON-RPC Method invocation
  107. * JSON-RPC Notification invocation
  108. * Simple Interface for implementing additional Server-Connectors beside HTTP
  109. * Positional and named parameters
  110. Package: libjsonrpccpp-server0-dbg
  111. Architecture: any
  112. Depends: libjsonrpccpp-common0-dbg (= ${binary:Version}),
  113. libjsonrpccpp-server0 (= ${binary:Version}),
  114. ${misc:Depends},
  115. ${shlibs:Depends}
  116. Section: debug
  117. Description: debugging symbols for libjsonrpccpp-server0
  118. This library provides classes to easily implement JSON-RPC C++ Server
  119. applications. It comes with a built in HTTP-Server connector
  120. (based on libmicrohttpd) for easy data exchange. It is fully JSON-RPC 2.0 and
  121. JSON-RPC 1.0 compatible, including:
  122. .
  123. * Type checking
  124. * Malformed request handling
  125. * Handling batch procedure calls
  126. * JSON-RPC Method invocation
  127. * JSON-RPC Notification invocation
  128. * Simple Interface for implementing additional Server-Connectors beside HTTP
  129. * Positional and named parameters
  130. .
  131. This package contains the debugging symbols for libjsonrpccpp-server0.
  132. Package: libjsonrpccpp-stub0
  133. Architecture: any
  134. Section: libdevel
  135. Pre-Depends: ${misc:Pre-Depends}
  136. Depends: libjsonrpccpp-common0, ${misc:Depends}, ${shlibs:Depends}
  137. Suggests: libjsonrpccpp-tools
  138. Description: library for stub generation of libjsonrpccpp based applications
  139. This package provides the stub generator library for the libjson-rpc-cpp
  140. framework. It can automatically generate full functioning C++ and JavaScript
  141. JSON-RPC Client classes, which are ready to use.
  142. .
  143. For JSON-RPC Server applications, this library can generate an abstract C++
  144. class which just has to be sub classed and implement all pure virtual methods.
  145. To make this possible, a interface description file (in the JSON format)
  146. is required, which lists all available methods with corresponding parameters
  147. and types.
  148. Package: libjsonrpccpp-stub0-dbg
  149. Architecture: any
  150. Section: debug
  151. Depends: libjsonrpccpp-common0-dbg (= ${binary:Version}),
  152. libjsonrpccpp-stub0 (= ${binary:Version}),
  153. ${misc:Depends},
  154. ${shlibs:Depends}
  155. Suggests: libjsonrpccpp-tools
  156. Description: debugging symbols for libjsonrpccpp-stub0
  157. This package provides the stub generator library for the libjson-rpc-cpp
  158. framework. It can automatically generate full functioning C++ and JavaScript
  159. JSON-RPC Client classes, which are ready to use.
  160. .
  161. For JSON-RPC Server applications, this library can generate an abstract C++
  162. class which just has to be sub classed and implement all pure virtual methods.
  163. To make this possible, a interface description file (in the JSON format)
  164. is required, which lists all available methods with corresponding parameters
  165. and types.
  166. .
  167. This package contains the debugging symbols for libjsonrpccpp-common0.
  168. Package: libjsonrpccpp-tools
  169. Architecture: any
  170. Section: libdevel
  171. Depends: libjsonrpccpp-stub0 (= ${binary:Version}),
  172. ${misc:Depends},
  173. ${shlibs:Depends}
  174. Suggests: libjsonrpccpp-dev
  175. Description: stub generator for libjsonrpccpp based applications
  176. This package provides the stub generator for the libjson-rpc-cpp framework.
  177. It can automatically generate full functioning C++ and JavaScript JSON-RPC
  178. Client classes, which are ready to use.
  179. .
  180. For JSON-RPC Server applications, this tool can generate an abstract C++ class
  181. which just has to be sub classed and implement all pure virtual methods. To
  182. make this possible, a simple interface description file (in the JSON format)
  183. is required, which lists all available methods with corresponding parameters
  184. and types.
  185. Package: libjsonrpccpp-dev
  186. Section: libdevel
  187. Architecture: any
  188. Depends: libcurl4-openssl-dev | libcurl4-nss-dev,
  189. libjsoncpp-dev,
  190. libjsonrpccpp-client0 (= ${binary:Version}),
  191. libjsonrpccpp-common0 (= ${binary:Version}),
  192. libjsonrpccpp-server0 (= ${binary:Version}),
  193. libjsonrpccpp-stub0 (= ${binary:Version}),
  194. libmicrohttpd-dev,
  195. ${misc:Depends}
  196. Description: development files for JSON-RPC C++ framework
  197. This package provides all required developer resources like header-files
  198. and statically linked libraries of the libjson-rpc-cpp framework.
  199. .
  200. Features of this framework include:
  201. .
  202. * Type checking
  203. * Malformed request handling
  204. * Handling batch procedure calls
  205. * JSON-RPC Method invocation
  206. * JSON-RPC Notification invocation
  207. * Simple Interface for implementing additional Server-Connectors beside HTTP
  208. * Positional and named parameters