dolphin-emu.SlackBuild 3.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122
  1. #!/bin/sh
  2. # Slackware build script for dolphin-emu
  3. # Copyright 2015-2019 orbea
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=dolphin-emu
  23. BRANCH=${BRANCH:-master}
  24. BUILD=${BUILD:-1}
  25. TAG=${TAG:-_git}
  26. if [ -z "$ARCH" ]; then
  27. case "$( uname -m )" in
  28. i?86) ARCH=i586 ;;
  29. arm*) ARCH=arm ;;
  30. *) ARCH=$( uname -m ) ;;
  31. esac
  32. fi
  33. CWD=$(pwd)
  34. TMP=${TMP:-/tmp/SBo}
  35. PKG=$TMP/package-$PRGNAM
  36. OUTPUT=${OUTPUT:-/tmp}
  37. if [ "$ARCH" = "i586" ] || [ "$ARCH" = "i686" ]; then
  38. printf %s\\n "$ARCH is not supported."
  39. exit 1
  40. elif [ "$ARCH" = "x86_64" ]; then
  41. SLKCFLAGS="-O2 -fPIC"
  42. LIBDIRSUFFIX="64"
  43. else
  44. SLKCFLAGS="-O2"
  45. LIBDIRSUFFIX=""
  46. fi
  47. set -eu
  48. rm -rf $PKG
  49. mkdir -p $TMP $PKG $OUTPUT
  50. cd $TMP
  51. rm -rf $PRGNAM
  52. git clone --depth=1 -b $BRANCH https://github.com/$PRGNAM/${PRGNAM%-*} $PRGNAM
  53. cd $PRGNAM
  54. [ "${COMMIT:=}" ] && git fetch --unshallow --tags && git checkout "$COMMIT"
  55. HEAD="$(git rev-parse --short HEAD)"
  56. DATE="$(git show -s --format=%cd --date=format:%Y.%m.%d)"
  57. VERSION="${DATE}_$HEAD"
  58. chown -R root:root .
  59. find -L . \
  60. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  61. -o -perm 511 \) -exec chmod 755 {} \; -o \
  62. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  63. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  64. if [ "${DEBUG:=0}" != 0 ]; then
  65. RELEASE=Debug
  66. SLKCFLAGS="$(printf %s "$SLKCFLAGS" | sed 's/-O2/-O0/')"
  67. else
  68. RELEASE=Release
  69. fi
  70. pkg-config --exists Qt5Core || QT=OFF
  71. [ "${ANALYTICS:=ON}" != ON ] && ANALYTICS=OFF
  72. [ "${DISCORD:=OFF}" != OFF ] && DISCORD=ON
  73. [ "${QT:=ON}" != ON ] && QT=OFF
  74. mkdir build
  75. cd build
  76. cmake -GNinja \
  77. -DCMAKE_C_FLAGS="$SLKCFLAGS" \
  78. -DCMAKE_CXX_FLAGS="$SLKCFLAGS" \
  79. -DCMAKE_INSTALL_PREFIX=/usr \
  80. -Dbindir=/usr/games \
  81. -Ddatadir=/usr/share/games/$PRGNAM \
  82. -Dmandir=/usr/man \
  83. -DENABLE_ANALYTICS=$ANALYTICS \
  84. -DUSE_DISCORD_PRESENCE=$DISCORD \
  85. -DENABLE_QT=$QT \
  86. -DDISTRIBUTOR="$(cat /etc/slackware-version)" \
  87. -DCMAKE_BUILD_TYPE=$RELEASE ..
  88. "${NINJA:=ninja}"
  89. DESTDIR=$PKG "$NINJA" install
  90. cd ..
  91. if [ "$DEBUG" = 0 ]; then
  92. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
  93. grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  94. fi
  95. find $PKG/usr/man -type f -exec gzip -9 {} \;
  96. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  97. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  98. cp -a license.txt *.md $PKG/usr/doc/$PRGNAM-$VERSION
  99. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  100. mkdir -p $PKG/install
  101. cat $CWD/slack-desc > $PKG/install/slack-desc
  102. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  103. cd $PKG
  104. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-${VERSION}_$BRANCH-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}