Gearsystem.SlackBuild 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123
  1. #!/bin/sh
  2. # Slackware build script for Gearsystem
  3. # Copyright 2018-2019 orbea
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=Gearsystem
  23. LIBNAM=$(printf %s $PRGNAM | tr 'A-Z' 'a-z')_libretro
  24. BRANCH=${BRANCH:-master}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_git}
  27. if [ -z "$ARCH" ]; then
  28. case "$( uname -m )" in
  29. i?86) ARCH=i586 ;;
  30. arm*) ARCH=arm ;;
  31. *) ARCH=$( uname -m ) ;;
  32. esac
  33. fi
  34. CWD=$(pwd)
  35. TMP=${TMP:-/tmp/SBo}
  36. PKG=$TMP/package-$PRGNAM
  37. OUTPUT=${OUTPUT:-/tmp}
  38. # requires patching the Makefile to properly use
  39. # the default CFLAGS and CXXFLAGS are probably fine
  40. if [ "$ARCH" = "i586" ]; then
  41. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  42. LIBDIRSUFFIX=""
  43. elif [ "$ARCH" = "i686" ]; then
  44. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  45. LIBDIRSUFFIX=""
  46. elif [ "$ARCH" = "x86_64" ]; then
  47. SLKCFLAGS="-O2 -fPIC"
  48. LIBDIRSUFFIX="64"
  49. else
  50. SLKCFLAGS="-O2"
  51. LIBDIRSUFFIX=""
  52. fi
  53. set -eu
  54. rm -rf $PKG
  55. mkdir -p $TMP $PKG $OUTPUT
  56. cd $TMP
  57. rm -rf $PRGNAM
  58. git clone --depth=1 -b $BRANCH https://github.com/drhelius/$PRGNAM
  59. cd $PRGNAM
  60. HEAD="$(git rev-parse --short HEAD)"
  61. DATE="$(git show -s --format=%cd --date=format:%Y.%m.%d)"
  62. VERSION="${DATE}_$HEAD"
  63. chown -R root:root .
  64. find -L . \
  65. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  66. -o -perm 511 \) -exec chmod 755 {} \; -o \
  67. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  68. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  69. [ "${DEBUG:=0}" != 0 ] && DEBUG=1
  70. make -C platforms/libretro DEBUG=$DEBUG
  71. install -Dm0644 platforms/libretro/$LIBNAM.so $PKG/usr/lib${LIBDIRSUFFIX}/libretro/$LIBNAM.so
  72. install -Dm0644 platforms/libretro/$LIBNAM.info $PKG/usr/lib${LIBDIRSUFFIX}/libretro/info/$LIBNAM.info
  73. mkdir -p $PKG/install
  74. cat $CWD/slack-desc > $PKG/install/slack-desc
  75. if pkg-config --exists Qt5Core && pkg-config --exists sdl2; then
  76. ( cd platforms/linux/$PRGNAM
  77. qmake-qt5 $PRGNAM.pro \
  78. QMAKE_CC="${CC:-cc}" \
  79. QMAKE_CXX="${CXX:-c++}" \
  80. QMAKE_CFLAGS="$SLKCFLAGS" \
  81. QMAKE_CXXFLAGS="$SLKCFLAGS"
  82. make
  83. install -Dm0755 $PRGNAM $PKG/usr/games/$PRGNAM
  84. install -Dm0644 $PRGNAM.6 $PKG/usr/man/man6/$PRGNAM.6
  85. install -Dm0644 $PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
  86. )
  87. cat > $PKG/install/doinst.sh <<EOF
  88. if [ -x /usr/bin/update-desktop-database ]; then
  89. /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
  90. fi
  91. EOF
  92. find $PKG/usr/man -type f -exec gzip -9 {} \;
  93. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  94. fi
  95. if [ $DEBUG = 0 ]; then
  96. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
  97. grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  98. fi
  99. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  100. cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
  101. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  102. cd $PKG
  103. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-${VERSION}_$BRANCH-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}