pkgconf.SlackBuild 4.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143
  1. #!/bin/sh
  2. # Slackware build script for pkgconf
  3. # Copyright 2018-2019 orbea
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=pkgconf
  23. BRANCH=${BRANCH:-master}
  24. BUILD=${BUILD:-1}
  25. TAG=${TAG:-_git}
  26. if [ -z "$ARCH" ]; then
  27. case "$( uname -m )" in
  28. i?86) ARCH=i586 ;;
  29. arm*) ARCH=arm ;;
  30. *) ARCH=$( uname -m ) ;;
  31. esac
  32. fi
  33. CWD=$(pwd)
  34. TMP=${TMP:-/tmp/SBo}
  35. PKG=$TMP/package-$PRGNAM
  36. OUTPUT=${OUTPUT:-/tmp}
  37. if [ "$ARCH" = "i586" ]; then
  38. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  39. LIBDIRSUFFIX=""
  40. elif [ "$ARCH" = "i686" ]; then
  41. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  42. LIBDIRSUFFIX=""
  43. elif [ "$ARCH" = "x86_64" ]; then
  44. SLKCFLAGS="-O2 -fPIC"
  45. LIBDIRSUFFIX="64"
  46. else
  47. SLKCFLAGS="-O2"
  48. LIBDIRSUFFIX=""
  49. fi
  50. set -eu
  51. rm -rf $PKG
  52. mkdir -p $TMP $PKG $OUTPUT
  53. cd $TMP
  54. rm -rf $PRGNAM
  55. git clone --depth=1 -b $BRANCH https://git.sr.ht/~kaniini/$PRGNAM
  56. cd $PRGNAM
  57. [ "${COMMIT:=}" ] && git fetch --unshallow --tags && git checkout "$COMMIT"
  58. HEAD="$(git rev-parse --short HEAD)"
  59. DATE="$(git show -s --format=%cd --date=format:%Y.%m.%d)"
  60. VERSION="${DATE}_$HEAD"
  61. chown -R root:root .
  62. find -L . \
  63. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  64. -o -perm 511 \) -exec chmod 755 {} \; -o \
  65. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  66. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  67. [ "${DEBUG:=0}" != 0 ] &&
  68. SLKCFLAGS="$(printf %s "$SLKCFLAGS" | sed 's/-O2/-O0 -g/')"
  69. autoreconf -fi
  70. CFLAGS="$SLKCFLAGS" \
  71. ./configure \
  72. --prefix=/usr \
  73. --libdir=/usr/lib${LIBDIRSUFFIX} \
  74. --mandir=/usr/man \
  75. --docdir=/usr/doc/$PRGNAM-$VERSION \
  76. --with-pkg-config-dir=/usr/local/lib${LIBDIRSUFFIX}/pkgconfig:/usr/local/share/pkgconfig:/usr/lib${LIBDIRSUFFIX}/pkgconfig:/usr/share/pkgconfig \
  77. --with-system-libdir=/usr/local/lib${LIBDIRSUFFIX}:/lib${LIBDIRSUFFIX}:/usr/lib${LIBDIRSUFFIX} \
  78. --disable-static \
  79. --build=$ARCH-slackware-linux
  80. make
  81. make install DESTDIR=$PKG
  82. ( cd $PKG/usr/bin; ln -sf $PRGNAM pkg-config )
  83. if [ "$ARCH" = x86_64 ]; then
  84. if [ -f /usr/lib/libgcc_s.so ]; then
  85. arch='i586 x86_64'
  86. else
  87. arch=x86_64
  88. fi
  89. else
  90. arch=i586
  91. fi
  92. platform=slackware-linux-gnu
  93. # adapted from fedora
  94. eval "set -- $arch"
  95. for i do
  96. case "$i" in
  97. i586) libdir= ;;
  98. x86_64) libdir=64 ;;
  99. esac
  100. sed -e "s|@TARGET_PLATFORM@|$i-$platform|" \
  101. -e "s|@PKGCONF_LIBDIRS@|/usr/local/lib$libdir/pkgconfig:/usr/local/share/pkgconfig:/usr/lib$libdir/pkgconfig:/usr/share/pkgconfig|" \
  102. -e "s|@PKGCONF_SYSLIBDIR@|/usr/local/lib$libdir:/lib$libdir:/usr/lib$libdir|" \
  103. -e "s|@PKGCONF_SYSINCDIR@|/usr/local/include:/usr/include|" \
  104. < $CWD/platform-pkg-config.in \
  105. > $PKG/usr/bin/$i-$platform-pkg-config
  106. chmod 0755 $PKG/usr/bin/$i-$platform-pkg-config
  107. done
  108. if [ "$DEBUG" = 0 ]; then
  109. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
  110. grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  111. fi
  112. find $PKG/usr/man -type f -exec gzip -9 {} \;
  113. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  114. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  115. cp -a AUTHORS COPYING NEWS README.md $PKG/usr/doc/$PRGNAM-$VERSION
  116. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  117. mkdir -p $PKG/install
  118. cat $CWD/slack-desc > $PKG/install/slack-desc
  119. cd $PKG
  120. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-${VERSION}_$BRANCH-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}