cantarell-fonts_0.0.12.bb 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. SUMMARY = "Cantarell font family"
  2. DESCRIPTION = "The Cantarell typeface family is a contemporary Humanist \
  3. sans serif, and is used by the GNOME project for its user \
  4. interface and the Fedora project."
  5. SECTION = "x11/fonts"
  6. LICENSE = "GPLv2"
  7. LIC_FILES_CHKSUM = "file://COPYING;md5=0fa7ab31d2f5d9fc9b8b272f79a061c2"
  8. PR = "r0"
  9. RDEPENDS_${PN} = "fontconfig-utils"
  10. inherit allarch
  11. SRC_URI = "http://download.gnome.org/sources/${PN}/0.0/${PN}-${PV}.tar.xz \
  12. file://21-cantarell-hinting.conf"
  13. do_configure() {
  14. ./configure --prefix=${prefix} --with-fontdir=${datadir}/fonts/truetype --with-configdir=${sysconfdir}/fonts/conf.d --disable-source-rebuild
  15. }
  16. do_compile() {
  17. make
  18. }
  19. do_install() {
  20. oe_runmake DESTDIR=${D} install
  21. install -d ${D}${sysconfdir}/fonts/conf.d/
  22. install -m 0644 ${WORKDIR}/21-cantarell-hinting.conf ${D}${sysconfdir}/fonts/conf.d/
  23. }
  24. pkg_postinst_${PN} () {
  25. #!/bin/sh
  26. fc-cache
  27. }
  28. PACKAGES = "${PN}"
  29. FILES_${PN} += "${sysconfdir} ${datadir}"
  30. SRC_URI[md5sum] = "6011af6f0a0a5ebdd1e35691ab346401"
  31. SRC_URI[sha256sum] = "3d509e1117dd92a6b80ef8b2586c89e178dc21a03c7c61f5c50772def5c4934b"