rubygem-gdk_pixbuf2.SlackBuild 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121
  1. #!/bin/sh
  2. # Slackware build script for rubygem-gdk_pixbuf2
  3. # Copyright 2015 Dugan Chen Canada
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=rubygem-gdk_pixbuf2
  23. VERSION=${VERSION:-2.2.5}
  24. BUILD=${BUILD:-1}
  25. TAG=${TAG:-_SBo}
  26. SRCNAM=gdk_pixbuf2
  27. if [ -z "$ARCH" ]; then
  28. case "$( uname -m )" in
  29. i?86) ARCH=i486 ;;
  30. arm*) ARCH=arm ;;
  31. *) ARCH=$( uname -m ) ;;
  32. esac
  33. fi
  34. CWD=$(pwd)
  35. TMP=${TMP:-/tmp/SBo}
  36. PKG=$TMP/package-$PRGNAM
  37. OUTPUT=${OUTPUT:-/tmp}
  38. if [ "$ARCH" = "i486" ]; then
  39. SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  40. LIBDIRSUFFIX=""
  41. elif [ "$ARCH" = "i686" ]; then
  42. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  43. LIBDIRSUFFIX=""
  44. elif [ "$ARCH" = "x86_64" ]; then
  45. SLKCFLAGS="-O2 -fPIC"
  46. LIBDIRSUFFIX="64"
  47. else
  48. SLKCFLAGS="-O2"
  49. LIBDIRSUFFIX=""
  50. fi
  51. set -e
  52. rm -rf $PKG
  53. mkdir -p $TMP $PKG $OUTPUT
  54. cd $TMP
  55. # Get the full path of the ruby installation, for gems
  56. DESTDIR=$( ruby -r rbconfig -e '
  57. include RbConfig
  58. printf("%s/%s/gems/%s\n",
  59. CONFIG["libdir"],
  60. CONFIG["RUBY_INSTALL_NAME"],
  61. CONFIG["ruby_version"]
  62. )
  63. ')
  64. # print a friendly warning of unsatisfied ":runtime" dependencies
  65. # good to leave in place, even if the gem doesn't have any dependencies.
  66. # things could always change
  67. gem specification $CWD/$SRCNAM-$VERSION.gem | \
  68. ruby -r yaml -r rbconfig -e '
  69. c = RbConfig::CONFIG
  70. path = sprintf("%s/%s/gems/%s",
  71. c["libdir"],
  72. c["RUBY_INSTALL_NAME"],
  73. c["ruby_version"])
  74. sys_gemspecs = Dir.glob(path + "/specifications/**/*.gemspec").map {|g| gs = Gem::Specification.load(g); gs.name }
  75. obj = Gem::Specification.from_yaml($stdin)
  76. obj.dependencies.each {|dep|
  77. if not(dep.type == :runtime)
  78. next
  79. end
  80. if not(sys_gemspecs.include?(dep.name))
  81. $stderr.write("WARNING: #{dep.name} gem not found\n")
  82. sleep 0.5
  83. end
  84. }'
  85. gem install \
  86. --local \
  87. --no-update-sources \
  88. --ignore-dependencies \
  89. --backtrace \
  90. --install-dir $PKG/$DESTDIR \
  91. --bindir $PKG/usr/bin \
  92. $CWD/$SRCNAM-$VERSION.gem
  93. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  94. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  95. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  96. tar -x -O --file=$CWD/$SRCNAM-$VERSION.gem data.tar.gz \
  97. | tar -xz -C $PKG/usr/doc/$PRGNAM-$VERSION --file=- \
  98. README
  99. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  100. mkdir -p $PKG/install
  101. cat $CWD/slack-desc > $PKG/install/slack-desc
  102. cd $PKG
  103. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}