ruby-native-package-installer.SlackBuild 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131
  1. #!/bin/sh
  2. # Slackware build script for ruby-native-package-installer
  3. # Copyright 2017 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=ruby-native-package-installer
  23. VERSION=${VERSION:-1.0.4}
  24. BUILD=${BUILD:-1}
  25. TAG=${TAG:-_SBo}
  26. SRCNAM=native-package-installer
  27. if [ -z "$ARCH" ]; then
  28. case "$( uname -m )" in
  29. i?86) ARCH=i586 ;;
  30. arm*) ARCH=arm ;;
  31. *) ARCH=$( uname -m ) ;;
  32. esac
  33. fi
  34. CWD=$(pwd)
  35. TMP=${TMP:-/tmp/SBo}
  36. PKG=$TMP/package-$PRGNAM
  37. OUTPUT=${OUTPUT:-/tmp}
  38. if [ "$ARCH" = "i586" ]; then
  39. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  40. LIBDIRSUFFIX=""
  41. elif [ "$ARCH" = "i686" ]; then
  42. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  43. LIBDIRSUFFIX=""
  44. elif [ "$ARCH" = "x86_64" ]; then
  45. SLKCFLAGS="-O2 -fPIC"
  46. LIBDIRSUFFIX="64"
  47. else
  48. SLKCFLAGS="-O2"
  49. LIBDIRSUFFIX=""
  50. fi
  51. set -e
  52. rm -rf $PKG
  53. mkdir -p $TMP $PKG $OUTPUT
  54. cd $TMP
  55. # Get the full path of the ruby installation, for gems
  56. DESTDIR=$( ruby -r rbconfig -e '
  57. include RbConfig
  58. printf("%s/%s/gems/%s\n",
  59. CONFIG["libdir"],
  60. CONFIG["RUBY_INSTALL_NAME"],
  61. CONFIG["ruby_version"]
  62. )
  63. ')
  64. # Get only ruby_version for later use
  65. RUBYVER=$( ruby -r rbconfig -e '
  66. include RbConfig
  67. printf("%s\n",
  68. CONFIG["ruby_version"]
  69. )
  70. ')
  71. # print a friendly warning of unsatisfied ":runtime" dependencies
  72. # good to leave in place, even if the gem doesn't have any dependencies.
  73. # things could always change
  74. gem specification $CWD/$SRCNAM-$VERSION.gem | \
  75. ruby -r yaml -r rbconfig -e '
  76. c = RbConfig::CONFIG
  77. path = sprintf("%s/%s/gems/%s",
  78. c["libdir"],
  79. c["RUBY_INSTALL_NAME"],
  80. c["ruby_version"])
  81. sys_gemspecs = Dir.glob(path + "/specifications/**/*.gemspec").map {|g| gs = Gem::Specification.load(g); gs.name }
  82. obj = Gem::Specification.from_yaml($stdin)
  83. obj.dependencies.each {|dep|
  84. if not(dep.type == :runtime)
  85. next
  86. end
  87. if not(sys_gemspecs.include?(dep.name))
  88. $stderr.write("WARNING: #{dep.name} gem not found\n")
  89. sleep 0.5
  90. end
  91. }'
  92. gem install \
  93. --local \
  94. --no-update-sources \
  95. --ignore-dependencies \
  96. --backtrace \
  97. --install-dir $PKG/$DESTDIR \
  98. --bindir $PKG/usr/bin \
  99. $CWD/$SRCNAM-$VERSION.gem
  100. # Strip binaries and libraries.
  101. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  102. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  103. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  104. for df in doc/text/news.md doc/text/lgpl-3.txt doc/text/gpl-3.txt README.md ; do
  105. ln -s /usr/lib${LIBDIRSUFFIX}/ruby/gems/${RUBYVER}/gems/${SRCNAM}-${VERSION}/${df} \
  106. $PKG/usr/doc/$PRGNAM-$VERSION/$(basename ${df}) ;
  107. done
  108. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  109. mkdir -p $PKG/install
  110. cat $CWD/slack-desc > $PKG/install/slack-desc
  111. cd $PKG
  112. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}