makemkv.SlackBuild 4.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154
  1. #!/bin/sh
  2. # Slackware build script for MakeMKV
  3. # Copyright 2017 T3slider <t3slider@gmail.com>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=makemkv
  23. VERSION=${VERSION:-1.10.6}
  24. BUILD=${BUILD:-1}
  25. TAG=${TAG:-_SBo}
  26. if [ -z "$ARCH" ]; then
  27. case "$( uname -m )" in
  28. i?86) ARCH=i586 ;;
  29. arm*) ARCH=arm ;;
  30. *) ARCH=$( uname -m ) ;;
  31. esac
  32. fi
  33. CWD=$(pwd)
  34. TMP=${TMP:-/tmp/SBo}
  35. PKG=$TMP/package-$PRGNAM
  36. OUTPUT=${OUTPUT:-/tmp}
  37. if [ "$ARCH" = "i586" ]; then
  38. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  39. ARCHDIR=i386
  40. LIBDIRSUFFIX=""
  41. elif [ "$ARCH" = "i686" ]; then
  42. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  43. ARCHDIR=i386
  44. LIBDIRSUFFIX=""
  45. elif [ "$ARCH" = "x86_64" ]; then
  46. # -fPIC was causing segfaults...
  47. SLKCFLAGS="-O2"
  48. ARCHDIR=amd64
  49. LIBDIRSUFFIX="64"
  50. else
  51. SLKCFLAGS="-O2"
  52. ARCHDIR=i386
  53. LIBDIRSUFFIX=""
  54. fi
  55. # Note: MakeMKV now includes a mips32 binary, but since there is no official
  56. # MIPS Slackware port I'm ignoring it unless someone complains. Still no ARM
  57. # version.
  58. # Spoof libaacs and libbdplus? (This will override real libaacs.so.0 and
  59. # libbdplus.so.0 upon package installation if they are present! If you want
  60. # to spoof this, you should ensure those packages are not installed!)
  61. FAKELIBS=${FAKELIBS:-no}
  62. # Include 32-bit mmdtsdec for decoding DTS-HD Master Audio on 64-bit systems?
  63. MULTILIB=${MULTILIB:-no}
  64. set -e
  65. rm -rf $PKG
  66. mkdir -p $TMP $PKG $OUTPUT
  67. cd $TMP
  68. # Build the open source component first...
  69. rm -rf ${PRGNAM}-oss-${VERSION}
  70. tar xvf $CWD/${PRGNAM}-oss-${VERSION}.tar.gz
  71. cd ${PRGNAM}-oss-${VERSION}
  72. chown -R root:root .
  73. find -L . \
  74. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  75. -o -perm 511 \) -exec chmod 755 {} \; -o \
  76. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  77. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  78. CFLAGS="$SLKCFLAGS" \
  79. CXXFLAGS="$SLKCFLAGS" \
  80. ./configure \
  81. --prefix=/usr \
  82. --libdir=/usr/lib${LIBDIRSUFFIX} \
  83. --sysconfdir=/etc \
  84. --localstatedir=/var \
  85. --mandir=/usr/man \
  86. --docdir=/usr/doc/$PRGNAM-$VERSION \
  87. --build=$ARCH-slackware-linux
  88. make
  89. make install DESTDIR=$PKG
  90. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  91. cp -a License.txt $PKG/usr/doc/$PRGNAM-$VERSION
  92. # Now extract/copy the closed source component...
  93. cd $TMP
  94. rm -rf ${PRGNAM}-bin-${VERSION}
  95. tar xvf $CWD/${PRGNAM}-bin-${VERSION}.tar.gz
  96. cd ${PRGNAM}-bin-${VERSION}
  97. chown -R root:root .
  98. find -L . \
  99. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  100. -o -perm 511 \) -exec chmod 755 {} \; -o \
  101. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  102. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  103. # The makefile now supports DESTDIR so it's easier to use it. This is just
  104. # removing the mandatory interactive EULA agreement which might confuse
  105. # SlackBuild users (check the README which tells you to read the EULA anyway...)
  106. sed -i "s/^\(install:\).*/\1/" Makefile
  107. # We will not leave CPU detection up to the makefile here just in case...
  108. make install ARCH=$ARCHDIR ARCH_OK=1 DESTDIR=$PKG
  109. # Remove the 32-bit mmdtsdec binary on 64-bit systems unless MULTILIB=yes
  110. # See http://www.makemkv.com/dtshd/ for setup information.
  111. # Despite claims of the developer, mmdtsdec will *not* work on pure 64-bit
  112. # systems.
  113. if [ "$ARCH" = "x86_64" -a "$MULTILIB" = "no" ]; then
  114. rm -f $PKG/usr/bin/mmdtsdec
  115. fi
  116. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  117. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  118. cp -a src/eula_en_linux.txt $PKG/usr/doc/$PRGNAM-$VERSION
  119. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  120. cat $CWD/README.issues > $PKG/usr/doc/$PRGNAM-$VERSION/README.issues
  121. if [ "$FAKELIBS" != "no" ]; then
  122. cd $PKG/usr/lib${LIBDIRSUFFIX}
  123. ln -s libmmbd.so.0 libaacs.so.0
  124. ln -s libmmbd.so.0 libbdplus.so.0
  125. fi
  126. mkdir -p $PKG/install
  127. cat $CWD/slack-desc > $PKG/install/slack-desc
  128. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  129. cd $PKG
  130. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}