vivacious-colors-gtk-theme.SlackBuild 2.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465
  1. #!/bin/sh
  2. #
  3. # Slackware build script for vivacious-colors-gtk-theme.
  4. #
  5. # Copyright 2016 Philip van der Hoeven, Almere, The Netherlands
  6. # All rights reserved.
  7. #
  8. # Redistribution and use of this script, with or without modification, is
  9. # permitted provided that the following conditions are met:
  10. #
  11. # 1. Redistributions of this script must retain the above copyright
  12. # notice, this list of conditions and the following disclaimer.
  13. #
  14. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  15. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  16. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  17. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  18. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  19. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  20. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  21. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  22. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  23. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  24. PRGNAM="vivacious-colors-gtk-theme"
  25. VERSION=${VERSION:-16.04.4}
  26. BUILD=${BUILD:-1}
  27. TAG=${TAG:-_SBo}
  28. ARCH=noarch
  29. TMP=${TMP:-/tmp/SBo}
  30. PKG=$TMP/package-$PRGNAM
  31. OUTPUT=${OUTPUT:-/tmp}
  32. CWD=$(pwd)
  33. set -e
  34. SRCVER=$(echo $VERSION| sed 's/\./-/g')
  35. SRCNAM="Vivacious-Colors-GTK-3-18-Theme-v-${SRCVER}-LTS.tar.gz"
  36. rm -rf $PKG
  37. mkdir -p $TMP $PKG $OUTPUT
  38. cd $TMP
  39. rm -rf $PRGNAM-$VERSION
  40. mkdir $PRGNAM-$VERSION
  41. cd $PRGNAM-$VERSION
  42. tar xvf $CWD/$SRCNAM
  43. chown -R root:root .
  44. mkdir -p $PKG/usr/share/themes/
  45. cp -a * $PKG/usr/share/themes/
  46. rm $PKG/usr/share/themes/README-Manual.txt
  47. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  48. cp -a README-Manual.txt $PKG/usr/doc/$PRGNAM-$VERSION
  49. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  50. mkdir -p $PKG/install
  51. cat $CWD/slack-desc > $PKG/install/slack-desc
  52. cd $PKG
  53. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}