murrine-themes.SlackBuild 2.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071
  1. #!/bin/sh
  2. # Slackware build script for murrine-themes
  3. # Copyright 2011-2016 Petar Petrov slackalaxy@gmail.com
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. # Many thanks to Debian for bundling all these themes together!
  23. PRGNAM=murrine-themes
  24. VERSION=${VERSION:-0.98.11}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. ARCH=noarch
  28. ORIGINAL=Murrine # Default theme for XFWM
  29. CWD=$(pwd)
  30. TMP=${TMP:-/tmp/SBo}
  31. PKG=$TMP/package-$PRGNAM
  32. OUTPUT=${OUTPUT:-/tmp}
  33. set -e
  34. rm -rf $PKG
  35. mkdir -p $TMP $PKG $OUTPUT
  36. cd $TMP
  37. rm -rf $PRGNAM
  38. tar xvf $CWD/${PRGNAM}_${VERSION}.tar.xz
  39. tar xvf $CWD/${ORIGINAL}Xfwm.tar.bz2 -C $PRGNAM/usr/share/themes
  40. cd $PRGNAM
  41. chown -R root:root .
  42. # Zap Debian's executable .png and .xpm files :)
  43. find -L . \
  44. -type d -exec chmod 755 {} \; -o \
  45. -type f -exec chmod 644 {} \;
  46. cd $TMP/$PRGNAM/usr/share/themes
  47. # Copy everything, including the original XFCE Murrina theme from here:
  48. # http://xfce-look.org/content/show.php/Murrine++Xfwm+Theme?content=43083
  49. mkdir -p $PKG/usr/share/themes
  50. cp -a * $PKG/usr/share/themes
  51. cd $TMP/$PRGNAM/debian
  52. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  53. cp -a changelog copyright README $PKG/usr/doc/$PRGNAM-$VERSION
  54. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  55. mkdir -p $PKG/install
  56. cat $CWD/slack-desc > $PKG/install/slack-desc
  57. cd $PKG
  58. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}