gtk-theme-Blackbird.SlackBuild 2.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. #!/bin/sh
  2. #
  3. # Slackware build script for gtk-theme-Blackbird.
  4. #
  5. # Copyright 2015 Edinaldo P. Silva, Rio de Janeiro, Brazil.
  6. # All rights reserved.
  7. #
  8. # Redistribution and use of this script, with or without modification, is
  9. # permitted provided that the following conditions are met:
  10. #
  11. # 1. Redistributions of this script must retain the above copyright
  12. # notice, this list of conditions and the following disclaimer.
  13. #
  14. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  15. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  16. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  17. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  18. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  19. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  20. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  21. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  22. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  23. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  24. PRGNAM="gtk-theme-Blackbird"
  25. VERSION=${VERSION:-0.4}
  26. BUILD=${BUILD:-1}
  27. TAG=${TAG:-_SBo}
  28. ARCH=noarch
  29. TMP=${TMP:-/tmp/SBo}
  30. PKG=$TMP/package-$PRGNAM
  31. OUTPUT=${OUTPUT:-/tmp}
  32. CWD=$(pwd)
  33. set -e
  34. SRCNAM="Blackbird"
  35. rm -rf $PKG
  36. mkdir -p $TMP $PKG $OUTPUT
  37. cd $TMP
  38. rm -rf $PRGNAM-$VERSION
  39. mkdir $PRGNAM-$VERSION
  40. tar xvf $CWD/$SRCNAM-$VERSION.tar.gz -C $PRGNAM-$VERSION
  41. cd $PRGNAM-$VERSION
  42. chown -R root:root .
  43. # remove git stuff.
  44. rm -f Blackbird-$VERSION/.gitignore
  45. mkdir -p $PKG/usr/share/themes
  46. cp -a Blackbird-$VERSION $PKG/usr/share/themes/Blackbird
  47. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  48. mv $PKG/usr/share/themes/Blackbird/README $PKG/usr/doc/$PRGNAM-$VERSION
  49. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  50. mkdir -p $PKG/install
  51. cat $CWD/slack-desc > $PKG/install/slack-desc
  52. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  53. cd $PKG
  54. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}