faba-mono-icons.SlackBuild 2.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465
  1. #!/bin/sh
  2. #
  3. # Slackware build script for faba-mono-icons.
  4. #
  5. # Copyright 2015 Edinaldo P. Silva, Rio de Janeiro, Brazil.
  6. # All rights reserved.
  7. #
  8. # Redistribution and use of this script, with or without modification, is
  9. # permitted provided that the following conditions are met:
  10. #
  11. # 1. Redistributions of this script must retain the above copyright
  12. # notice, this list of conditions and the following disclaimer.
  13. #
  14. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  15. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  16. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  17. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  18. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  19. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  20. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  21. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  22. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  23. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  24. PRGNAM="faba-mono-icons"
  25. VERSION=${VERSION:-4.2}
  26. BUILD=${BUILD:-1}
  27. TAG=${TAG:-_SBo}
  28. ARCH=noarch
  29. TMP=${TMP:-/tmp/SBo}
  30. PKG=$TMP/package-$PRGNAM
  31. OUTPUT=${OUTPUT:-/tmp}
  32. CWD=$(pwd)
  33. set -e
  34. rm -rf $PKG
  35. mkdir -p $TMP $PKG $OUTPUT
  36. cd $TMP
  37. rm -rf $PRGNAM-$VERSION
  38. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  39. cd $PRGNAM-$VERSION
  40. chown -R root:root .
  41. find -L . \
  42. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  43. -o -perm 511 -o -perm 700 \) -exec chmod 755 {} \; -o \
  44. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  45. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  46. mkdir -p $PKG/usr/share/icons
  47. cp -a Faba-Mono Faba-Mono-Dark $PKG/usr/share/icons
  48. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  49. cp AUTHORS INSTALL LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
  50. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  51. mkdir -p $PKG/install
  52. cat $CWD/slack-desc > $PKG/install/slack-desc
  53. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  54. cd $PKG
  55. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}