clearlooks-classic-themes.SlackBuild 2.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071
  1. #!/bin/sh
  2. # Slackware build script for clearlooks-classic-themes
  3. # Copyright 2011-2016 Petar Petrov slackalaxy@gmail.com
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=clearlooks-classic-themes
  23. VERSION=${VERSION:-0.6.2}
  24. BUILD=${BUILD:-1}
  25. TAG=${TAG:-_SBo}
  26. ARCH=noarch
  27. SRCNAM=clearlooks
  28. CWD=$(pwd)
  29. TMP=${TMP:-/tmp/SBo}
  30. PKG=$TMP/package-$PRGNAM
  31. OUTPUT=${OUTPUT:-/tmp}
  32. set -e
  33. rm -rf $PKG
  34. mkdir -p $TMP $PKG $OUTPUT
  35. cd $TMP
  36. rm -rf $SRCNAM-$VERSION
  37. tar xvf $CWD/$SRCNAM-$VERSION.tar.bz2
  38. cd $SRCNAM-$VERSION
  39. chown -R root:root .
  40. find -L . \
  41. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  42. -exec chmod 755 {} \; -o \
  43. \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
  44. -exec chmod 644 {} \;
  45. cd themes
  46. install -D -m644 Clearlooks/gtk-2.0/gtkrc $PKG/usr/share/themes/Clearlooks-Classic/gtk-2.0/gtkrc
  47. install -D -m644 Clearlooks-DeepSky/gtk-2.0/gtkrc $PKG/usr/share/themes/Clearlooks-Deepsky/gtk-2.0/gtkrc
  48. install -D -m644 Clearlooks-Olive/gtk-2.0/gtkrc $PKG/usr/share/themes/Clearlooks-Olive/gtk-2.0/gtkrc
  49. install -D -m644 Clearlooks-Quicksilver/gtk-2.0/gtkrc $PKG/usr/share/themes/Clearlooks-Quicksilver/gtk-2.0/gtkrc
  50. cd ..
  51. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  52. cp -a \
  53. AUTHORS ChangeLog COPYING CREDITS INSTALL README TODO \
  54. $PKG/usr/doc/$PRGNAM-$VERSION
  55. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  56. mkdir -p $PKG/install
  57. cat $CWD/slack-desc > $PKG/install/slack-desc
  58. cd $PKG
  59. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}