04_fix_const.patch 547 B

1234567891011121314
  1. Index: pinball-0.3.1/base/Config.cpp
  2. ===================================================================
  3. --- pinball-0.3.1.orig/base/Config.cpp 2009-10-13 18:33:38.000000000 +0200
  4. +++ pinball-0.3.1/base/Config.cpp 2009-10-13 18:37:12.000000000 +0200
  5. @@ -416,7 +416,7 @@
  6. m_sDataDir = string(EM_DATADIR) + "/";
  7. m_sExeDir = "./";
  8. if ( *( m_sDataDir.c_str() ) != '/' ) {
  9. - char* ptr=0;
  10. + const char* ptr=0;
  11. char* ptrw = 0;
  12. //cout<<"relative to exe file"<<endl;
  13. ptr = (strrchr(argv0,'/')); // unix /cygwin / check win32